# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^Invoice Nr\.?\s*(?<arvenumber>[^\W_]+)[\s_]"
test_str = ("...\n"
"Some nr_11687767_ other 101308591\n"
"Invoice Nr.\n"
"M230714_some text\n"
"Kirjeldus\n"
"...\n"
"Sometimes it is terminated by newline\n\n"
"...\n"
"This nr_11687767_KMKR_EE101308591\n"
"Invoice Nr.\n"
"M230714\n"
"01.05.2023\n"
"Item\n"
"...\n"
"or by other white space delimiter :\n\n"
"...\n"
"Some nr_11687767_ Text\n"
"Invoice Nr M230714 Date 01.05.2023\n"
"Desc\n"
"...")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.