re = /^Invoice Nr\.?\s*(?<arvenumber>[^\W_]+)[\s_]/m
str = '...
Some nr_11687767_ other 101308591
Invoice Nr.
M230714_some text
Kirjeldus
...
Sometimes it is terminated by newline
...
This nr_11687767_KMKR_EE101308591
Invoice Nr.
M230714
01.05.2023
Item
...
or by other white space delimiter :
...
Some nr_11687767_ Text
Invoice Nr M230714 Date 01.05.2023
Desc
...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end