package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\s*,\s*[12]\d+`)
var str = `Name , PIN
John ,12345
Harry ,01234
Tom, 24659`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}