$re = '/.*\s*,\s*[12]\d+/';
$str = 'Name , PIN
John ,12345
Harry ,01234
Tom, 24659';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);