const regex = /.*\s*,\s*[12]\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\s*,\\s*[12]\\d+', 'g')
const str = `Name , PIN
John ,12345
Harry ,01234
Tom, 24659`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}