#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w(?=\w*?(\w\2?\b)))+?(\w\w?)\2"
Local $sString = "bonbon" & @CRLF & _
"tuktuk" & @CRLF & _
"killbill" & @CRLF & _
"ohlaaaala" & @CRLF & _
"" & @CRLF & _
"antidisestablishmentarianism " & @CRLF & _
"Half of everything is luck." & @CRLF & _
"And the other half?" & @CRLF & _
"Fate."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")