using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w(?=\w*?(\w\2?\b)))+?(\w\w?)\2";
string input = @"bonbon
tuktuk
killbill
ohlaaaala
antidisestablishmentarianism
Half of everything is luck.
And the other half?
Fate.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}