$re = '/(\w(?=\w*?(\w\2?\b)))+?(\w\w?)\2/m';
$str = 'bonbon
tuktuk
killbill
ohlaaaala
antidisestablishmentarianism
Half of everything is luck.
And the other half?
Fate.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);