using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^`([^`]+)`_$";
string input = @"`Document Title`_
start_
Document Title_
`Document ` Title`_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}