package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^`([^`]+)`_$`)
var str = `\`Document Title\`_
start_
Document Title_
\`Document \` Title\`_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}