re = /^`([^`]+)`_$/m
str = '`Document Title`_
start_
Document Title_
`Document ` Title`_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end