#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z0-9]{16}"
Local $sString = "setting-bs_b77f423715d2b991-node" & @CRLF & _
"setting-bs_b77f423715d2b991-eggs" & @CRLF & _
"setting-bs_b77f423715d2b991-cheese" & @CRLF & _
"setting-bs_b14835f519bf447d-ham"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")