re = /[a-z0-9]{16}/m
str = 'setting-bs_b77f423715d2b991-node
setting-bs_b77f423715d2b991-eggs
setting-bs_b77f423715d2b991-cheese
setting-bs_b14835f519bf447d-ham'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end