import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z0-9]{16}";
final String string = "setting-bs_b77f423715d2b991-node\n"
+ "setting-bs_b77f423715d2b991-eggs\n"
+ "setting-bs_b77f423715d2b991-cheese\n"
+ "setting-bs_b14835f519bf447d-ham";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}