#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)(?!0|127)\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}"
Local $sString = "127.3.65.7" & @CRLF & _
"alkjgfbvui vluiybr vk ru r127.0.0.1fal;iufnaw waoun" & @CRLF & _
"12.0.1.5" & @CRLF & _
"mjhgvjg0.0.0.0kjuycuj" & @CRLF & _
"0.0.0.0" & @CRLF & _
"0.0.0.0" & @CRLF & _
"gare bloing r pgnao wyin212.2.174.64" & @CRLF & _
"207.71.31.224" & @CRLF & _
"awuie nvp; vwa rv;awiu n ;lkirjght94.206.93.104ta;wourit mrt'" & @CRLF & _
"172.20.128.1" & @CRLF & _
"172.20.164.207" & @CRLF & _
"172.20.164.203" & @CRLF & _
"172.20.164.209" & @CRLF & _
"1.8.0.144"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")