re = /(?<!\d)(?!0|127)\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}/m
str = '127.3.65.7
alkjgfbvui vluiybr vk ru r127.0.0.1fal;iufnaw waoun
12.0.1.5
mjhgvjg0.0.0.0kjuycuj
0.0.0.0
0.0.0.0
gare bloing r pgnao wyin212.2.174.64
207.71.31.224
awuie nvp; vwa rv;awiu n ;lkirjght94.206.93.104ta;wourit mrt\'
172.20.128.1
172.20.164.207
172.20.164.203
172.20.164.209
1.8.0.144'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end