# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\d)(?!0|127)\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}"
test_str = ("127.3.65.7\n"
"alkjgfbvui vluiybr vk ru r127.0.0.1fal;iufnaw waoun\n"
"12.0.1.5\n"
"mjhgvjg0.0.0.0kjuycuj\n"
"0.0.0.0\n"
"0.0.0.0\n"
"gare bloing r pgnao wyin212.2.174.64\n"
"207.71.31.224\n"
"awuie nvp; vwa rv;awiu n ;lkirjght94.206.93.104ta;wourit mrt'\n"
"172.20.128.1\n"
"172.20.164.207\n"
"172.20.164.203\n"
"172.20.164.209\n"
"1.8.0.144")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.