using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|(?m)^foobar\b).*?\K\bfoo\b";
string input = @"foobar foo foo foo foo
foobaz foo foo foo foo foo";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}