$re = '/(?:\G(?!\A)|(?m)^foobar\b).*?\K\bfoo\b/';
$str = 'foobar foo foo foo foo
foobaz foo foo foo foo foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);