re = /(?:\G(?!\A)|(?m)^foobar\b).*?\K\bfoo\b/
str = 'foobar foo foo foo foo
foobaz foo foo foo foo foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end