import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+\\s+:\\s+\\*{3}\\s+(\\w.*)$";
final String string = "LOADER_ERROR : *** Failure The UserId, Password or Account is invalid., attempts:1\n"
+ "LOADER_ERROR : *** Time out waiting for a response.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}