using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=info\"":).*(?=,\""mac\"")";
string input = @"message = """"{""info"":{""keyVersion"":1,""timestamp"":""2020-11-05 20:00:00"",""encryptedData"":""75657374696f6e732068617665207265636569""},""mac"":""4d6163204b65792049732048455245""}""""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}