import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=info\\\":).*(?=,\\\"mac\\\")";
final String string = "message = \"\"\"{\"info\":{\"keyVersion\":1,\"timestamp\":\"2020-11-05 20:00:00\",\"encryptedData\":\"75657374696f6e732068617665207265636569\"},\"mac\":\"4d6163204b65792049732048455245\"}\"\"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}