re = /(?<=info\":).*(?=,\"mac\")/m
str = 'message = """{"info":{"keyVersion":1,"timestamp":"2020-11-05 20:00:00","encryptedData":"75657374696f6e732068617665207265636569"},"mac":"4d6163204b65792049732048455245"}"""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end