#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d*[a|b]\d\d"
Local $sString = "1a01 Ὁμώνυμα λέγεται ὧν ὄνομα μόνον κοινόν, ὁ δὲ κατὰ " & @CRLF & _
"1a02 τοὔνομα λόγος τῆς οὐσίας ἕτερος, οἷον ζῷον ὅ τε ἄνθρω– " & @CRLF & _
"1a03 πος καὶ τὸ γεγραμμένον· τούτων γὰρ ὄνομα μόνον κοινόν, " & @CRLF & _
"1a04 ὁ δὲ κατὰ τοὔνομα λόγος τῆς οὐσίας ἕτερος· ἐὰν γὰρ " & @CRLF & _
"1a05 ἀποδιδῷ τις τί ἐστιν αὐτῶν ἑκατέρῳ τὸ ζῴῳ εἶναι, ἴδιον " & @CRLF & _
"1a06 ἑκατέρου λόγον ἀποδώσει. " & @CRLF & _
" " & @CRLF & _
"1a06 συνώνυμα δὲ λέγεται ὧν τό τε " & @CRLF & _
"1a07 ὄνομα κοινὸν καὶ ὁ κατὰ τοὔνομα λόγος τῆς οὐσίας ὁ αὐτός, " & @CRLF & _
"1a08 οἷον ζῷον ὅ τε ἄνθρωπος καὶ ὁ βοῦς· τούτων γὰρ ἑκάτερον " & @CRLF & _
"1a09 κοινῷ ὀνόματι προσαγορεύεται ζῷον, καὶ ὁ λόγος δὲ " & @CRLF & _
"1a10 τῆς οὐσίας ὁ αὐτός· ἐὰν γὰρ ἀποδιδῷ τις τὸν ἑκατέρου " & @CRLF & _
"1a11 λόγον τί ἐστιν αὐτῶν ἑκατέρῳ τὸ ζῴῳ εἶναι, τὸν αὐτὸν " & @CRLF & _
"1a12 λόγον ἀποδώσει. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")