const regex = /\d*[a|b]\d\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d*[a|b]\\d\\d', 'gm')
const str = `1a01 Ὁμώνυμα λέγεται ὧν ὄνομα μόνον κοινόν, ὁ δὲ κατὰ
1a02 τοὔνομα λόγος τῆς οὐσίας ἕτερος, οἷον ζῷον ὅ τε ἄνθρω–
1a03 πος καὶ τὸ γεγραμμένον· τούτων γὰρ ὄνομα μόνον κοινόν,
1a04 ὁ δὲ κατὰ τοὔνομα λόγος τῆς οὐσίας ἕτερος· ἐὰν γὰρ
1a05 ἀποδιδῷ τις τί ἐστιν αὐτῶν ἑκατέρῳ τὸ ζῴῳ εἶναι, ἴδιον
1a06 ἑκατέρου λόγον ἀποδώσει.
1a06 συνώνυμα δὲ λέγεται ὧν τό τε
1a07 ὄνομα κοινὸν καὶ ὁ κατὰ τοὔνομα λόγος τῆς οὐσίας ὁ αὐτός,
1a08 οἷον ζῷον ὅ τε ἄνθρωπος καὶ ὁ βοῦς· τούτων γὰρ ἑκάτερον
1a09 κοινῷ ὀνόματι προσαγορεύεται ζῷον, καὶ ὁ λόγος δὲ
1a10 τῆς οὐσίας ὁ αὐτός· ἐὰν γὰρ ἀποδιδῷ τις τὸν ἑκατέρου
1a11 λόγον τί ἐστιν αὐτῶν ἑκατέρῳ τὸ ζῴῳ εἶναι, τὸν αὐτὸν
1a12 λόγον ἀποδώσει. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}