use strict;
my $str = '1a01 Ὁμώνυμα λέγεται ὧν ὄνομα μόνον κοινόν, ὁ δὲ κατὰ
1a02 τοὔνομα λόγος τῆς οὐσίας ἕτερος, οἷον ζῷον ὅ τε ἄνθρω–
1a03 πος καὶ τὸ γεγραμμένον· τούτων γὰρ ὄνομα μόνον κοινόν,
1a04 ὁ δὲ κατὰ τοὔνομα λόγος τῆς οὐσίας ἕτερος· ἐὰν γὰρ
1a05 ἀποδιδῷ τις τί ἐστιν αὐτῶν ἑκατέρῳ τὸ ζῴῳ εἶναι, ἴδιον
1a06 ἑκατέρου λόγον ἀποδώσει.
1a06 συνώνυμα δὲ λέγεται ὧν τό τε
1a07 ὄνομα κοινὸν καὶ ὁ κατὰ τοὔνομα λόγος τῆς οὐσίας ὁ αὐτός,
1a08 οἷον ζῷον ὅ τε ἄνθρωπος καὶ ὁ βοῦς· τούτων γὰρ ἑκάτερον
1a09 κοινῷ ὀνόματι προσαγορεύεται ζῷον, καὶ ὁ λόγος δὲ
1a10 τῆς οὐσίας ὁ αὐτός· ἐὰν γὰρ ἀποδιδῷ τις τὸν ἑκατέρου
1a11 λόγον τί ἐστιν αὐτῶν ἑκατέρῳ τὸ ζῴῳ εἶναι, τὸν αὐτὸν
1a12 λόγον ἀποδώσει. ';
my $regex = qr/\d*[a|b]\d\d/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}