using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\.)(\w+)(?:\['?""?(\w+)""?'?\])?";
string substitution = @".$1[$2";
string input = @"Game.ObjectsById[1].buy
Game.shimmerTypes['golden'].popFunc
Game.setVolume";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}