import re
regex = re.compile(r"(?:^|\.)(\w+)(?:\['?\"?(\w+)\"?'?\])?", flags=re.MULTILINE)
test_str = ("Game.ObjectsById[1].buy\n"
"Game.shimmerTypes['golden'].popFunc\n"
"Game.setVolume")
subst = ".$1[$2"
result = regex.sub(subst, test_str)
if result:
print(result)