$re = '/(?:^|\.)(\w+)(?:\[\'?"?(\w+)"?\'?\])?/m';
$str = 'Game.ObjectsById[1].buy
Game.shimmerTypes[\'golden\'].popFunc
Game.setVolume';
$subst = ".$1[$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;