using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^ \w-]";
string substitution = @"";
string input = @"__--===#$#$%#ABZ12;.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}