package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^ \w-]`)
var str = `__--===#$#$%#ABZ12;.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}