const regex = /(?<=["\s])[^\s]+?\s?=\s?"\$\{(?:\w*)\}"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=["\\s])[^\\s]+?\\s?=\\s?"\\$\\{(?:\\w*)\\}"', 'gm')
const str = `<a onclick="javascript:collapse('displayText','hideText','whyInfo-arrow-image')"><span sd:text="\${whyInfoLabel}">Learn more about Authentication</span> <img id="whyInfo-arrow-image" sd:src="\${downwardArrowImage}" height="20" width="20" >`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}