$re = '/(?<=["\s])[^\s]+?\s?=\s?"\$\{(?:\w*)\}"/m';
$str = '<a onclick="javascript:collapse(\'displayText\',\'hideText\',\'whyInfo-arrow-image\')"><span sd:text="${whyInfoLabel}">Learn more about Authentication</span> <img id="whyInfo-arrow-image" sd:src="${downwardArrowImage}" height="20" width="20" >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);