re = /(?<=["\s])[^\s]+?\s?=\s?"\$\{(?:\w*)\}"/m
str = '<a onclick="javascript:collapse(\'displayText\',\'hideText\',\'whyInfo-arrow-image\')"><span sd:text="${whyInfoLabel}">Learn more about Authentication</span> <img id="whyInfo-arrow-image" sd:src="${downwardArrowImage}" height="20" width="20" >'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end