#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+\b|\(\d+\)$"
Local $sString = "123(456)" & @CRLF & _
"123" & @CRLF & _
"(456)" & @CRLF & _
"abc(456)" & @CRLF & _
"123(efg)" & @CRLF & _
"And these are not valid combinations and should not be matched:" & @CRLF & _
"" & @CRLF & _
"abc(efg)" & @CRLF & _
"abc" & @CRLF & _
"(efg)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")