// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+\b|\(\d+\)$").unwrap();
let string = "123(456)
123
(456)
abc(456)
123(efg)
And these are not valid combinations and should not be matched:
abc(efg)
abc
(efg)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}