import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\b|\\(\\d+\\)$";
final String string = "123(456)\n"
+ "123\n"
+ "(456)\n"
+ "abc(456)\n"
+ "123(efg)\n"
+ "And these are not valid combinations and should not be matched:\n\n"
+ "abc(efg)\n"
+ "abc\n"
+ "(efg)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}