using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"HTTP\/(\d\.\d) (\d\d\d) (.*)";
string input = @"HTTP/1.1 200 OK
Content-Type: text/html; charset=utf-8
Server: hhttpp
<!DOCTYPE HTML>
<html><body>
<h1>Hello, World!</h1>
</body></html>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}