package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)HTTP\/(\d\.\d) (\d\d\d) (.*)`)
var str = `HTTP/1.1 200 OK
Content-Type: text/html; charset=utf-8
Server: hhttpp
<!DOCTYPE HTML>
<html><body>
<h1>Hello, World!</h1>
</body></html>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}