use strict;
my $str = '{"id":"FWAX014","price":18,"quantity":1}';
my $regex = qr/(?<={|,)"(\w+)"/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";