package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)課長(?:補佐(?:代理(?:心得)?)?)?`)
var str = `課長、課長補佐、課長補佐代理、課長補佐代理心得
課長心得、課長代理 -- これにマッチして欲しくないのであれば誤検出
課長次第、課長志願 -- 妥当と思われるマッチ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}