import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "課長(?:補佐(?:代理(?:心得)?)?)?";
final String string = "課長、課長補佐、課長補佐代理、課長補佐代理心得\n\n"
+ "課長心得、課長代理 -- これにマッチして欲しくないのであれば誤検出\n\n"
+ "課長次第、課長志願 -- 妥当と思われるマッチ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}