const regex = /課長(?:補佐(?:代理(?:心得)?)?)?(?!心得|代理)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('課長(?:補佐(?:代理(?:心得)?)?)?(?!心得|代理)', 'gm')
const str = `課長、課長補佐、課長補佐代理、課長補佐代理心得
課長心得、課長代理 -- 部分マッチを排除できた
課長次第、課長志願 -- 妥当と思えるマッチ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}