import Foundation
let pattern = #"課長(?:補佐(?:代理(?:心得)?)?)?(?!心得|代理)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
課長、課長補佐、課長補佐代理、課長補佐代理心得
課長心得、課長代理 -- 部分マッチを排除できた
課長次第、課長志願 -- 妥当と思えるマッチ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)