using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\()?(\d+)(?(1)\)\-|\-)(\d+\-\d+)$";
string input = @"123-456-7890
(111-111-1111
111)-111-1111
(123)-456-7890";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}