package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\()?(\d+)(?(1)\)\-|\-)(\d+\-\d+)$`)
var str = `123-456-7890
(111-111-1111
111)-111-1111
(123)-456-7890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}