re = /^(\()?(\d+)(?(1)\)\-|\-)(\d+\-\d+)$/m
str = '123-456-7890
(111-111-1111
111)-111-1111
(123)-456-7890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end