#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?ms)\A(?:\d{2}/\d{2}/\d{2}(?:\d{2})?|−−DATE−−)\s.*\s\p{Lu}{3}$"
Local $sString = "08/03/2020 NOVUS HOME Mortgage Company TRU" & @CRLF & _
" MORTGAGE" & @CRLF & _
" 07/08/2020 FACTUAL DATA Mortgage Reporter XPN" & @CRLF & _
" 07/08/2020 FCTUALDATA EFX" & @CRLF & _
" 07/08/2020 NOVUS HOME Mortgage Company TRU" & @CRLF & _
" MORTGAGE" & @CRLF & _
" 07/07/2020 CROSSCOUNTRY Mortgage Loan TRU" & @CRLF & _
" MORTGAG" & @CRLF & _
" 07/07/2020 FACTUAL DATA Mortgage Reporter XPN" & @CRLF & _
" 07/07/2020 FCTUALDATA EFX" & @CRLF & _
" 05/21/2020 CAP ONE NA Bank Credit Card XPN" & @CRLF & _
" 05/21/2020 CAPITAL ONE Credit Card TRU" & @CRLF & _
" 05/21/2020 CAPITALONE Bank EFX" & @CRLF & _
" 05/20/2020 CROSSCOUNTRY Mortgage Loan TRU" & @CRLF & _
" MORTGAG" & @CRLF & _
" 05/20/2020 FACTUAL DATA Mortgage Reporter XPN" & @CRLF & _
" 05/20/2020 FCTUALDATA EFX" & @CRLF & _
" 05/20/2020 FINGERHUT/WEBBANK Finance Company XPN" & @CRLF & _
" 05/07/2020 EMS EFX" & @CRLF & _
" 05/07/2020 GROW FINANCIAL CREDI Credit Bureau/Mortgage TRU" & @CRLF & _
" Processing" & @CRLF & _
" Co-Applicant" & @CRLF & _
" No inquiry records found."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")