# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?ms)\A(?:\d{2}/\d{2}/\d{2}(?:\d{2})?|−−DATE−−)\s.*\s\p{Lu}{3}$"
test_str = ("08/03/2020 NOVUS HOME Mortgage Company TRU\n"
" MORTGAGE\n"
" 07/08/2020 FACTUAL DATA Mortgage Reporter XPN\n"
" 07/08/2020 FCTUALDATA EFX\n"
" 07/08/2020 NOVUS HOME Mortgage Company TRU\n"
" MORTGAGE\n"
" 07/07/2020 CROSSCOUNTRY Mortgage Loan TRU\n"
" MORTGAG\n"
" 07/07/2020 FACTUAL DATA Mortgage Reporter XPN\n"
" 07/07/2020 FCTUALDATA EFX\n"
" 05/21/2020 CAP ONE NA Bank Credit Card XPN\n"
" 05/21/2020 CAPITAL ONE Credit Card TRU\n"
" 05/21/2020 CAPITALONE Bank EFX\n"
" 05/20/2020 CROSSCOUNTRY Mortgage Loan TRU\n"
" MORTGAG\n"
" 05/20/2020 FACTUAL DATA Mortgage Reporter XPN\n"
" 05/20/2020 FCTUALDATA EFX\n"
" 05/20/2020 FINGERHUT/WEBBANK Finance Company XPN\n"
" 05/07/2020 EMS EFX\n"
" 05/07/2020 GROW FINANCIAL CREDI Credit Bureau/Mortgage TRU\n"
" Processing\n"
" Co-Applicant\n"
" No inquiry records found.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.